読者です 読者をやめる 読者になる 読者になる

Error ITMS -90362"Invalid info.plist valueエラー!!

はじめに

やっとこざアプリの審査作業を行っているのですが、xcodeよりアプリをアップロードする際に今度は以下のエラーが発生しました

ERROR ITMS-90362: "Invalid Info.plist value. The value for the key 'MinimumOSVersion' in bundle *****.app/Frameworks/*****.framework is invalid. The minimum value is 8.0"

もはや若干わけのわからない状況になっているのですが、、、

ライブラリのReadmeなどをみるとios7が最低バージョンとなっているので問題ないと思っていたのですが、上手くいってない状況でした。
いろいろググっていたら、ios7でswiftで開発する場合にcocoapodsのPodfileの「!use_frameworks」を使う場合はios8以上でないとダメのようでした。

これを外したらiTuneConnectに無事にアップロートできました。
その後に「*****-Bridging-Header.h」に以下のimportを追記

#import <****/****.h>

swiftファイルの「#import ****」を削除しました

xcode7にバージョンアップした時に全く逆の作業した記憶もあるのですが、、、
とりあえず、上手くいったのでよしとすることにしました

以上です